Idle revving suddenly started to go high - MG-Rover.org Forums
 
 
 
Go Back   MG-Rover.org Forums > Model Specific Forums > MG ZR / Rover 25, 200 & Streetwise

Reply
 
Thread Tools Rate Thread Display Modes
Old 26-04-2012, 08:44   #1
ironeagleuk
Registered User
 

Join Date: Jan 2008
Location: Folkestone, Kent
Car: Rover 25 1.4iXL
Posts: 3,895
Idle revving suddenly started to go high

Got car out this morning as usual, parked it while locking garage, and car is revving between 1500 and 1700 revs while the car is sat idling.

Has only started today...seemed fine yesterday.

What is the cause of this, and is it easy to fix?

Is it the idle control valve? Have heard of it, but don't know what it does.

Drove to work normally, and revs go below those that it was sat at whilst idling when in gear. But as soon as I stop rather than between the 900 and 1000 mark as normal, it goes from betwen 1500 and 1700 constantly up and down.
ironeagleuk is offline   Reply With Quote Quick reply to this message

Sponsored Links
Advertisement
 
Old 26-04-2012, 08:48   #2
Roverlike
Registered User
 

Join Date: Aug 2009
Location: Split, Croatia
Car: Rover 200 (95-99) 'Bubble Shape'
Posts: 8,389
Resistor on the throtle body that controls idle revs and not letting it get on 800 immediately if you are going to give new higher revs on engine?
It well may be that this resistor is playing up and needs replacing...

Try to make a check of that resistor and see if it is the problem...



Part #3 is the one I am aiming to. Electric part of it can start playing up.

Last edited by Roverlike; 26-04-2012 at 09:16.
Roverlike is offline   Reply With Quote Quick reply to this message

Old 26-04-2012, 09:47   #3
Beatonator
Registered User
 
Moon Lander Champion!Tournaments Won: 1

Join Date: Jan 2010
Location: W. Sussex
Car: MG ZR 1.4 & Rover 200 1.1
Posts: 6,124
I would have pointed more towards the Throttlebody as a whole.

We had the exact same issue on our 211. Fine when driving but if idle for a time it started to over-rev. Once the car was driven again and cold air got in, it settled down.

We had a plastic throttlebody and we reckon it was warping with the heat when idle and jammed the vavle open, when it cooled down it obviously returned to normal.

My suggestion is buy a replacement Alloy throttlebody. One of the local guys on here provided & fitted mine for me for 20

Hasn't done it since.
Beatonator is offline   Reply With Quote Quick reply to this message

Old 26-04-2012, 14:04   #4
Blueser
Registered User
 

Join Date: Feb 2010
Car: KENTAUR Rover 25 1.4 16V 76 KW (2004)
Posts: 637
Cool

Quote:
Originally Posted by ironeagleuk View Post
Got car out this morning as usual, parked it while locking garage, and car is revving between 1500 and 1700 revs while the car is sat idling.

Has only started today...seemed fine yesterday.

What is the cause of this, and is it easy to fix?

Is it the idle control valve? Have heard of it, but don't know what it does.

Drove to work normally, and revs go below those that it was sat at whilst idling when in gear. But as soon as I stop rather than between the 900 and 1000 mark as normal, it goes from betwen 1500 and 1700 constantly up and down.
In my case.
Before and after
Quote:
Originally Posted by Blueser
Disconnect the battery and put the live lead to the earth that will discharge the system leave it like that for an hour then re-connect the battery and then start the car as soon as it start push down on the throttle and hold it at 2000 rpm for 3 mins then release. See how you get on with that let me know as doing that will re-set the ecu and holding the RPM will help it learn its parameters again.
It was not the desired result.

But after 200 miles flown, learn its parameters again and "MYSTERY - ROVER IDLE PROBLEM" is resolved in my case.
Tachometer needle is stable at idle and respond "sharply" as a sword.
Reached the desired result.
My happiness has no end.



Before
http://www.youtube.com/watch?v=Z5SUGw5yxpI
After resolved
http://www.youtube.com/watch?v=bYwHP...-5PPis4O4hzHE=
Blueser is offline   Reply With Quote Quick reply to this message

Old 26-04-2012, 14:45   #5
ironeagleuk
Registered User
 

Join Date: Jan 2008
Location: Folkestone, Kent
Car: Rover 25 1.4iXL
Posts: 3,895
Well bizarely I just went out to lunch to have a fiddle with it....and the car is idling as normal now....so am not sure what happened, or how it fixed itself between 8:30am and 2pm
ironeagleuk is offline   Reply With Quote Quick reply to this message

Old 26-04-2012, 14:48   #6
Roverlike
Registered User
 

Join Date: Aug 2009
Location: Split, Croatia
Car: Rover 200 (95-99) 'Bubble Shape'
Posts: 8,389
Quote:
Originally Posted by ironeagleuk View Post
Well bizarely I just went out to lunch to have a fiddle with it....and the car is idling as normal now....so am not sure what happened, or how it fixed itself between 8:30am and 2pm
At least you have something to look at if happens again.

I hope it will not happen again ...
Roverlike is offline   Reply With Quote Quick reply to this message

Old 26-04-2012, 14:49   #7
ironeagleuk
Registered User
 

Join Date: Jan 2008
Location: Folkestone, Kent
Car: Rover 25 1.4iXL
Posts: 3,895
Quote:
Originally Posted by Roverlike View Post
At least you have something to look at if happens again.

I hope it will not happen again ...
Likewise.

Thanks everyone for suggestions and help
ironeagleuk is offline   Reply With Quote Quick reply to this message

Old 26-04-2012, 15:49   #8
Beatonator
Registered User
 
Moon Lander Champion!Tournaments Won: 1

Join Date: Jan 2010
Location: W. Sussex
Car: MG ZR 1.4 & Rover 200 1.1
Posts: 6,124
After re-reading the original post, I dont think it would be the situation I posted due due to it not having time to heat up, unless you move at a snails pace to lock the garage!

Glad to hear all is ok
Beatonator is offline   Reply With Quote Quick reply to this message

Old 26-04-2012, 17:46   #9
ironeagleuk
Registered User
 

Join Date: Jan 2008
Location: Folkestone, Kent
Car: Rover 25 1.4iXL
Posts: 3,895
Quote:
Originally Posted by Beatonator View Post
After re-reading the original post, I dont think it would be the situation I posted due due to it not having time to heat up, unless you move at a snails pace to lock the garage!

Glad to hear all is ok
Nope....reverse car out of garage....exit car and lock door, get back in car.

It was one I got out to lock garage door I noticed the high revving and thought...."that's not right"

Just hope it doesn't do it tomorrow morning
ironeagleuk is offline   Reply With Quote Quick reply to this message

Old 09-05-2012, 13:27   #10
ironeagleuk
Registered User
 

Join Date: Jan 2008
Location: Folkestone, Kent
Car: Rover 25 1.4iXL
Posts: 3,895
Car has started to do this again more frequently now.

The Haynes manual says I need a new O ring and lube to refit.....does anyone know if I do actually need new ones if I just take it off and inspect it?
ironeagleuk is offline   Reply With Quote Quick reply to this message

Old 09-05-2012, 15:46   #11
northend
Supporter
 
northend's Avatar
 

Join Date: Jul 2010
Location: Preston
Car: Quantum 2+2, Mercedes SLK, MG TF 135, Ford Mondeo Estate, Suzuki Alto
Posts: 2,320
Garages
Sticky IACV?
__________________
This signature intentionally left blank.
northend is offline   Reply With Quote Quick reply to this message

Old 09-05-2012, 16:30   #12
ironeagleuk
Registered User
 

Join Date: Jan 2008
Location: Folkestone, Kent
Car: Rover 25 1.4iXL
Posts: 3,895
That's what am thinking, but don't want to dismantle unless I know I can get it back together
ironeagleuk is offline   Reply With Quote Quick reply to this message

Old 09-05-2012, 19:25   #13
rob dunster
Registered User
 

Join Date: Nov 2011
Location: tredegar gwent
Car: MGTF 115 Sunstorm/Rover 45 Spirit/Scimitar SE6A 3000V6/Saab 93t convertible.
Posts: 2,574
have a check of your temperature sender to ecu,if its failing will cause the ecu to alter fuelling and idle speed.
rob dunster is offline   Reply With Quote Quick reply to this message

Old 09-05-2012, 19:36   #14
ironeagleuk
Registered User
 

Join Date: Jan 2008
Location: Folkestone, Kent
Car: Rover 25 1.4iXL
Posts: 3,895
Quote:
Originally Posted by rob dunster View Post
have a check of your temperature sender to ecu,if its failing will cause the ecu to alter fuelling and idle speed.
That sounds complicated...what would that involve?
ironeagleuk is offline   Reply With Quote Quick reply to this message

Old 09-05-2012, 19:38   #15
rob dunster
Registered User
 

Join Date: Nov 2011
Location: tredegar gwent
Car: MGTF 115 Sunstorm/Rover 45 Spirit/Scimitar SE6A 3000V6/Saab 93t convertible.
Posts: 2,574
either code read the engine,and it will come up,if its dicky,or sustitute for a known good one,try second hand,or new,if they are not too dear.
rob dunster is offline   Reply With Quote Quick reply to this message

Old 09-05-2012, 20:03   #16
ironeagleuk
Registered User
 

Join Date: Jan 2008
Location: Folkestone, Kent
Car: Rover 25 1.4iXL
Posts: 3,895
Quote:
Originally Posted by rob dunster View Post
either code read the engine,and it will come up,if its dicky,or sustitute for a known good one,try second hand,or new,if they are not too dear.
There are no codes in mine except one telling me the cat is operating below effficiency, but that's been on for about 2 years
ironeagleuk is offline   Reply With Quote Quick reply to this message

Old 09-05-2012, 20:34   #17
rob dunster
Registered User
 

Join Date: Nov 2011
Location: tredegar gwent
Car: MGTF 115 Sunstorm/Rover 45 Spirit/Scimitar SE6A 3000V6/Saab 93t convertible.
Posts: 2,574
try what has been mentioned above,but would a cat failing cause the ecu to alter fuelling and revs as well?maybe its linked,just a guess though.
rob dunster is offline   Reply With Quote Quick reply to this message

Old 10-05-2012, 11:59   #18
Beatonator
Registered User
 
Moon Lander Champion!Tournaments Won: 1

Join Date: Jan 2010
Location: W. Sussex
Car: MG ZR 1.4 & Rover 200 1.1
Posts: 6,124
Quote:
Originally Posted by rob dunster View Post
have a check of your temperature sender to ecu,if its failing will cause the ecu to alter fuelling and idle speed.
How Odd. My missus told me the Rover 211 was over-revving on Tuesday. Most bizarre will have to have a check of the stuff listed in this thread. thinking some WD40...
Beatonator is offline   Reply With Quote Quick reply to this message

Old 10-05-2012, 12:17   #19
RyanZR
Temporary Seller
 

Join Date: Aug 2010
Location: Birmingham
Car: Solar Red 120
Posts: 2,736
got a 48mm derestirected throttle body mate if you need it. can send it at the same time as the steering wheel. its an alloy one and looking for 30. or 35 with the cable.
RyanZR is offline   Reply With Quote Quick reply to this message

Old 16-05-2012, 18:39   #20
ironeagleuk
Registered User
 

Join Date: Jan 2008
Location: Folkestone, Kent
Car: Rover 25 1.4iXL
Posts: 3,895
This is definately a random problem....it was idling high last night, but today it seems fine.

Am going to pop out and have a fiddle in abit in the hope I don't make it worse....I've got my Haynes manual handy to take things apart, I just hope I can get it all back together again
ironeagleuk is offline   Reply With Quote Quick reply to this message

Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the MG-Rover.org Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Revving high at idle t0m4ever MG ZR / Rover 25, 200 & Streetwise 2 23-09-2011 11:51
High Idle, Revving High saxonmatt Metro / Rover 100 7 10-02-2011 18:28
216 coupe revving high on idle(k series engine) djhaynes 'R8' Rovers (aka Wedges!!) 2 09-12-2008 21:13
revving high at idle. choke sensor? neil1280 MG ZR / Rover 25, 200 & Streetwise 5 10-11-2008 09:17
416Si high revving at idle matt416si Others 5 15-02-2006 10:28


All times are GMT. The time now is 15:40.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
ShowCase, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.