Immobiliser Fault?? - MG-Rover.org Forums
 
 
 
Go Back   MG-Rover.org Forums > Model Specific Forums > MG ZR / Rover 25, 200 & Streetwise

Reply
 
Thread Tools Rate Thread Display Modes
Old 27-11-2010, 20:30   #1
Kehaar
Registered User
 

Join Date: Nov 2010
Car: Rover 25
Posts: 2
Immobiliser Fault??

Evening Gents.

I have a problem with starting my 25 Diesel.
Today I got a spare key cut (new fob to be ordered when I have the cash)
I went to test it and obviously it would start the engine because the old fob was in my pocket, I briefly held it near the key in order to start it and it started ok. Drove back from the shops no problem.

Later on when I went to start the car, I notice that the red immobiliser LED on the dash was not lit. Tried starting the car with no luck, all the lights come on, glow plugs warm up but it doesn't spin over.

When I tried to pull the ECU plug out then back in, the red LED light comes on and I can start the car. But next time I stop, it wont start again.
Any suggestions?
I am thinking I may have confused the car when I pulled the fob away from the steering wheel the first time...


Thanks

Nick
Kehaar is offline   Reply With Quote Quick reply to this message

Sponsored Links
Advertisement
 
Old 27-11-2010, 21:13   #2
LORDPSK
Registered User
 

Join Date: Jun 2007
Location: NORTH WALES
Car: NOW HAVE A 25, 45 & 75
Posts: 2,542
Apart from locking and unlocking if you have remote locking and turning the immobiliser on and off the fob does not even have to be in the car for the car to run. Check the cars earth connections etc, connections on starter motor, etc.
LORDPSK is offline   Reply With Quote Quick reply to this message

Old 28-11-2010, 12:04   #3
Kehaar
Registered User
 

Join Date: Nov 2010
Car: Rover 25
Posts: 2
It looks more like the Immobiliser itself is at fault because the red LED on the dash doesn't light up except when I pull the ECU and re plug it in...

N
Kehaar is offline   Reply With Quote Quick reply to this message

Old 28-11-2010, 15:47   #4
technozen
Mmmm....Rover..
 
technozen's Avatar
 

Join Date: Mar 2002
Location: Brighton.
Car: 200vi & Freelander XEDi
Posts: 10,188
Send a message via MSN to technozen
Are you pulling the plug from the engine ECU or Alarm ECU?
__________________
I offer FREE engine/alarm diagnostics and fob coding (incl. Pektron fobs) to mg-rover.org Supporters - details here.
Fob not working? Common faults and fixes here.
Pektron BCU/SCU Faulty? This may be of some help. Full SCU programming and repair services available.
Discounted SCU/BCU Full Relay Replacement Service - only for Supporters - details here
Replacement relays for the Pektron SCU available - .org Supporters buy 4, 5th is free - PM for details.
technozen is offline   Reply With Quote Quick reply to this message

Old 28-11-2010, 15:52   #5
MG-ROVER-CODES
01379 669375
 
MG-ROVER-CODES's Avatar
 

Join Date: Aug 2009
Location: Suffolk / Norfolk
Car: Vauxhall ASTRA GTC VXR
Posts: 1,865
Blog Entries: 16
Eka code

Hi


If You require the eka code for your vehicle we can get this via the chassis number and this over rides the immobiliser so the car will start.
__________________
Trusted UK Supplier Of MG Rover Codes

Last edited by MG-ROVER-CODES; 29-11-2010 at 08:23.
MG-ROVER-CODES is offline   Reply With Quote Quick reply to this message

Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the MG-Rover.org Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
immobiliser fault big_fact_hunt MG ZS / Rover 45 & 400 12 08-02-2010 17:53
Alarm / Immobiliser Fault DOOD MG ZS / Rover 45 & 400 5 26-10-2009 15:19
strange immobiliser fault danmgzr105 MG ZR / Rover 25, 200 & Streetwise 8 20-03-2009 18:20
Rover 100 Immobiliser Fault Grizz Metro / Rover 100 2 11-01-2009 16:34
Electrical Fault - Immobiliser? SammyP MG ZR / Rover 25, 200 & Streetwise 2 17-10-2008 23:33


All times are GMT. The time now is 11:25.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
ShowCase, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.